Printing program

When the weekly program is printed using the “MW-S140.htm” template, the printing date is automatically placed at the bottom right.
Would it be possible to have the same thing with the “MW-Schedule_1.htm” template?
It would be interesting to follow the updates in case of successive changes on different dates.
Thanks in advance


⇒ Fill these information below:

  • Desktop OS (name and version): Windows 11
  • App OS (name and version): (if relevent)
  • TheocBase version: 2022.04.0
  • Language used: French

With admin rights:

  1. go to %program files%/Theocbase/templates
  2. copy to rename MW-Schedule_1.htm file into MW-Schedule-modif_1.htm
  3. open this new file to add:
  • those CSS declarations:
		#footer       { position: fixed; bottom: 1.02cm; width: 100%; margin: 0; }

just before the ended element </style>.

  • those HTML bloc:
    <section id="footer">
			<hr style="margin: 0 1.27cm; height: 1.50pt; border: none; padding: 0; background-color: rgb(101,97,100);">
			<hr style="margin: 1.25pt 1.27cm 0 1.27cm; height: 0.75pt; border: none; padding: 0; background-color: rgb(101,97,100);">
			<tr style="height: 0.85cm;">
				<td style="border-right: 2.00pt solid rgb(101,97,100); width: 73%;"></td>
					<h2 style="color: rgb(101,97,100);">
						<script type="text/javascript">
							document.write(new Date().toLocaleDateString());

⇒ this HTML section need to add after the main and before this <p>!REPEAT_START!</p>.
5. after, open TB and set this new template
6. next, try if the printing is good!

WARNING: this is not an official solution, and there is no guarantee that it will work!

Thank you for the quick reply.
This works perfectly by putting the date at the top of the page with gray lines.
I will study these lines of code to make slight modifications (not having the lines and lowering the date by 0.5 cm or 1 cm.
I’m taking advantage of this answer for another request:
Before the last update, when I printed with the “MW-Schedule_1.htm” template, I had the time AND the duration of the speech (see screenshot below).

Now the duration no longer appears. Jer can no longer find the option to check.
Can you help me ?

Hi. Have you adding the CSS code to put on bottom?

Normally, You do not do this ; one request = one post

During this time, you can go to the TheocBase (embedded) Help FAQ, particularly F1 > Printing > Printing Tags > Midweek Meeting and search/see about all *_TIME variables to include into the modified template!

I created a new FAQ: [Howto] Modifying Printing Templates

The template is coded to have EITHER/OR time/duration. (It is full of #IF !DURATION! #ELSE# !xxx_STARTTIME! code)
You set your preference in the blue bar ‘additional options’ in the print dialogue.

So either one of the following is probably true:

  1. You used a custom template (but kept the original name, so it was overwritten by the update). The custom template wrote duration after the title if the template was set to print start times for every item.

  2. Before the update the timing as printed in the workbook, was read as part of the theme

ad 1. The.pragmatic approach: If you go to the Program Files - TheocBase folder, you find one or more Rollback directories. Open the one with the highest number (next to latest version) and keep going until you come into the template folder. Check if the MW Schedule 1 in that folder has a different make date. If so, copy into the present template folder ( and change the number to 5 or 10 or 99, whatever, so you can easily identify it for starters and then also it won’t be overwritten on a next update) and try to see what it does.

ad 2. There is a (slim) possibility that the way TB reads the French workbook has changed, so the duration between brackets is no longer considered part of the title (this would bring it in line with other languages). But I think an update would not affect already imported titles. It would affect a re-import though.

  • Templates are same for all language!
  • It seems that MW-Schedule_1.htm template file has never defaulted to the duration shown in the screenshot. This seems to mean that the file in question has been modified by a third party.
  • Good idea to see into the olders folders to copy-paste this old modified file into the new folder

Thank you very much for your help.
I had in fact modified the Tempate file “MW-Schedule_1.htm”, but without saving it under a different name. So during the last update, my modified file was overwritten.
Thanks to your advice, I went and looked in the Rollback directories. And I found my modified file. That’s great. Now I’ve put it back in the Templates folder, making sure to give it another name.
Thank you very much for your help, your responsiveness and your desire to help.

1 Like

True, but if sth. were off with the regex for the particular language, the theme might unexpectedly continue until after the opening brackets for the time. I didn’t believe it was, and I didn’t even bother to test, but I didn’t want to exclude the possiibility. So option 1 applied. Glad @Loopy you got it working.

unless I’m mistaken, regex are not into templates files!

@Loopy: glad to you!

This topic was automatically closed 60 minutes after the last reply. New replies are no longer allowed.